summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorflorhizome <florhizome@posteo.net>2022-12-12 10:39:46 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-22 23:30:31 +0100
commitfc29138074f6b6bb804f3bcb7afaefe95b0e50d5 (patch)
tree3e07dbd9d17b04d6afc3a9e3b4860c1a32e8f2c5
parent6ce7904a85154fece2c159d26b39bfa54b36101a (diff)
gnu: emacs-dashboard: Update to 1.7.0-0.a69cc10.
* gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to 1.7.0-0.a69cc10. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 34 insertions, 31 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e4baa141f0..55eb279365 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23176,38 +23176,41 @@ Emacs minor mode to escape sequences in code.")
(license license:gpl3+))))
(define-public emacs-dashboard
- (package
- (name "emacs-dashboard")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rakanalh/emacs-dashboard")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1qv4cqjy2s2d2bysbq10vq1axpbd8qc3jn1s1r81lxqkcja8zasa"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-page-break-lines))
- (arguments
- '(#:include '("\\.el$" "\\.txt$" "\\.png$")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-dashboard-widgets
- ;; This phase fixes compilation error.
- (lambda _
- (chmod "dashboard-widgets.el" #o666)
- (emacs-substitute-variables "dashboard-widgets.el"
- ("dashboard-init-info"
- '(format "Loaded in %s" (emacs-init-time))))
- #t)))))
- (home-page "https://github.com/rakanalh/emacs-dashboard")
- (synopsis "Startup screen extracted from Spacemacs")
- (description "This package provides an extensible Emacs dashboard, with
+ (let ((version "1.7.0")
+ (commit "a69cc103aebd957f967e431399681b6d9d6b52fc")
+ (revision "0"))
+ (package
+ (name "emacs-dashboard")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rakanalh/emacs-dashboard")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c6snnpc9rp6zhhdz411wyh2wn56yq2cdmxxqsp1ibvac8cbb1pq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-page-break-lines))
+ (arguments
+ '(#:include '("\\.el$" "\\.txt$" "\\.png$")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-dashboard-widgets
+ ;; This phase fixes compilation error.
+ (lambda _
+ (chmod "dashboard-widgets.el" #o666)
+ (emacs-substitute-variables "dashboard-widgets.el"
+ ("dashboard-init-info"
+ '(format "Loaded in %s" (emacs-init-time))))
+ #t)))))
+ (home-page "https://github.com/rakanalh/emacs-dashboard")
+ (synopsis "Startup screen extracted from Spacemacs")
+ (description "This package provides an extensible Emacs dashboard, with
sections for bookmarks, projectil projects, org-agenda and more.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-slime-company
(package