summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:11 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:07:51 +0100
commitfdf2b2e459048c6e2e9d53fb97927c2912266fc8 (patch)
tree825ef77c0592ee0f431bdfc1aab9fb36a1bb8f47
parent17f5a0da47ac5ad5f50a8f36a988670fea8d4d2a (diff)
gnu: Update ocaml-qcheck to 0.20.
* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.20. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 972da2fd96..8bed5e9cc0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1688,7 +1688,7 @@ archive(native) = \"frontc.cmxa\""))))
(define-public ocaml-qcheck
(package
(name "ocaml-qcheck")
- (version "0.18.1")
+ (version "0.20")
(source
(origin
(method git-fetch)
@@ -1697,12 +1697,12 @@ archive(native) = \"frontc.cmxa\""))))
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0g3r8lrw6fsdphgpnp08saxyxk1vd3chpmb564ir2qnsp716vz6z"))))
+ (base32 "1r0m5p1dd06lbgfxqdpl1ya4vb8252z7hqkvdi9k444g4rx2ay3p"))))
(build-system dune-build-system)
(arguments
`(#:test-target "."))
(propagated-inputs
- (list ocaml-alcotest ocaml-ounit))
+ (list ocaml-alcotest ocaml-ounit ocaml-ppxlib))
(native-inputs
(list ocamlbuild))
(properties `((ocaml4.07-variant . ,(delay ocaml4.07-qcheck))))