summaryrefslogtreecommitdiff
path: root/distro/packages/patches/glibc-bootstrap-system.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/patches/glibc-bootstrap-system.patch
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/patches/glibc-bootstrap-system.patch')
-rw-r--r--distro/packages/patches/glibc-bootstrap-system.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/distro/packages/patches/glibc-bootstrap-system.patch b/distro/packages/patches/glibc-bootstrap-system.patch
deleted file mode 100644
index 7208cce3f4..0000000000
--- a/distro/packages/patches/glibc-bootstrap-system.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
-and popen(3) need to be tweaked to use the right shell. For the bootstrap
-glibc, we just use whatever `sh' can be found in $PATH. The final glibc
-instead uses the hard-coded absolute file name of `bash'.
-
---- a/sysdeps/posix/system.c
-+++ b/sysdeps/posix/system.c
-@@ -134,7 +134,7 @@ do_system (const char *line)
- INIT_LOCK ();
-
- /* Exec the shell. */
-- (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
-+ (void) __execvpe (SHELL_NAME, (char *const *) new_argv, __environ);
- _exit (127);
- }
- else if (pid < (pid_t) 0)
-
---- b/libio/iopopen.c 2012-06-30 21:12:34.000000000 +0200
-+++ b/libio/iopopen.c 2012-12-19 12:52:29.000000000 +0100
-@@ -226,7 +226,7 @@ _IO_new_proc_open (fp, command, mode)
- _IO_close (fd);
- }
-
-- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
-+ execlp ("sh", "sh", "-c", command, (char *) 0);
- _IO__exit (127);
- }
- _IO_close (child_end);