summaryrefslogtreecommitdiff
path: root/gnu/build
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/build
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
Merge branch 'master' into staging.
With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/build')
-rw-r--r--gnu/build/jami-service.scm9
-rw-r--r--gnu/build/linux-container.scm8
2 files changed, 9 insertions, 8 deletions
diff --git a/gnu/build/jami-service.scm b/gnu/build/jami-service.scm
index 0ceb03eb02..a00785f699 100644
--- a/gnu/build/jami-service.scm
+++ b/gnu/build/jami-service.scm
@@ -153,14 +153,11 @@ implementation detail used to identify the accounts in Jami."
(error message username))))
(define (account->username account)
- "Return USERNAME, the registered username associated with ACCOUNT, else its
-public key fingerprint."
- (or (assoc-ref account "Account.registeredName")
- (assoc-ref account "Account.username")))
+ "Return the public key fingerprint of ACCOUNT."
+ (assoc-ref account "Account.username"))
(define (id->username id)
- "Return USERNAME, the registered username associated with ID, else its
-public key fingerprint, else #f."
+ "Return the public key fingerprint corresponding to account with ID, else #f."
(account->username (id->account id)))
(define (get-accounts)
diff --git a/gnu/build/linux-container.scm b/gnu/build/linux-container.scm
index a0c8174721..72e3a45422 100644
--- a/gnu/build/linux-container.scm
+++ b/gnu/build/linux-container.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017-2019, 2022 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -233,7 +233,7 @@ that host UIDs (respectively GIDs) map to in the namespace."
;; The parent process must initialize the user namespace for the child
;; before it can boot. To negotiate this, a pipe is used such that the
;; child process blocks until the parent writes to it.
- (match (socketpair PF_UNIX SOCK_STREAM 0)
+ (match (socketpair PF_UNIX (logior SOCK_CLOEXEC SOCK_STREAM) 0)
((child . parent)
(let ((flags (namespaces->bit-mask namespaces)))
(match (clone flags)
@@ -442,6 +442,10 @@ return the exit status."
"Like 'container-excursion', but return the return value of THUNK."
(match (pipe)
((in . out)
+ ;; Make sure IN and OUT are not inherited if THUNK forks + execs.
+ (fcntl in F_SETFD FD_CLOEXEC)
+ (fcntl out F_SETFD FD_CLOEXEC)
+
(match (container-excursion pid
(lambda ()
(close-port in)