summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-15 11:18:25 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:18 +0800
commit2b1eb3c1cf45cf916e30c3b32b3526d90a636cd9 (patch)
tree29fb7ac63e1cf215fc4bce1dfab463b148eec6c8 /gnu/packages/admin.scm
parent397a6860f64ee6b7f768e614c53eaca610437f8a (diff)
gnu: uwufetch: Avoid top-level package references.
* gnu/packages/admin.scm (uwufetch)[arguments]: Use the grep and gawk provided by INPUTS, instead of the top-level variables.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f9fffcec2b..4ddd03fecf 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4074,15 +4074,15 @@ you are running, what theme or icon set you are using, etc.")
#~(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'patch-source-paths
- (lambda _
- (substitute* "fetch.c"
- (("grep")
- #$(file-append grep "/bin/grep"))
- (("awk")
- #$(file-append gawk "/bin/awk")))
- (substitute* "uwufetch.c"
- (("(/usr(/local)?)(.*;)" all _ _ rest)
- (string-append #$output rest)))))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((grep (search-input-file inputs "/bin/grep"))
+ (awk (search-input-file inputs "/bin/awk")))
+ (substitute* "fetch.c"
+ (("grep") grep)
+ (("awk") awk))
+ (substitute* "uwufetch.c"
+ (("(/usr(/local)?)(.*;)" all _ _ rest)
+ (string-append #$output rest))))))
;; TODO this will be fixed in the next release of uwufetch
(add-before 'install 'make-include-dir
(lambda _