summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-11-03 15:34:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-03 22:49:10 +0100
commitbbe7ea0d2751bd2c9b27dc63e963eb16a17539e0 (patch)
treeda0be00ceaef591e247f3687ed7e3c0bb1187a6e /gnu/packages/bioconductor.scm
parentf80de2f03ffc3bd514c107a11d14bee568e5fdb9 (diff)
gnu: Add r-sparsearray.
* gnu/packages/bioconductor.scm (r-sparsearray): New variable. Change-Id: Ibc5b5a518206d492dd5b912294da3967881b5ccd
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f8cd834357..5e44b3ad12 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -20973,6 +20973,43 @@ cell-specific biases, assignment of cell cycle phase, and detection of highly
variable and significantly correlated genes.")
(license license:gpl3)))
+(define-public r-sparsearray
+ (package
+ (name "r-sparsearray")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SparseArray" version))
+ (sha256
+ (base32 "0a1xg8vkjybgdr09bk2z4i82m06qnw2nhbzviyijadxiwvz6pgsz"))))
+ (properties `((upstream-name . "SparseArray")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocgenerics
+ r-iranges
+ r-matrix
+ r-matrixgenerics
+ r-matrixstats
+ r-s4arrays
+ r-s4vectors
+ r-xvector))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/SparseArray")
+ (synopsis
+ "Efficient in-memory representation of multidimensional sparse arrays")
+ (description
+ "The @code{SparseArray} package is an infrastructure package that
+provides an array-like container for efficient in-memory representation of
+multidimensional sparse data in R. The package defines the @code{SparseArray}
+virtual class and two concrete subclasses: @code{COO_SparseArray} and
+@code{SVT_SparseArray}. Each subclass uses its own internal representation of
+the nonzero multidimensional data, the \"COO layout\" and the \"SVT layout\",
+respectively. @code{SVT_SparseArray} objects mimic as much as possible the
+behavior of ordinary matrix and array objects in base R. In particular, they
+suppport most of the \"standard matrix and array API\" defined in base R and
+in the @code{matrixStats} package from CRAN.")
+ (license license:artistic2.0)))
+
(define-public r-sparsematrixstats
(package
(name "r-sparsematrixstats")