summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/chemistry.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm92
1 files changed, 0 insertions, 92 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 94803719ac..735d599d2d 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -128,35 +128,6 @@ science, and related areas. It offers flexible high quality rendering and a
powerful plugin architecture.")
(license license:bsd-3)))
-(define-public domainfinder
- (package
- (name "domainfinder")
- (version "2.0.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://bitbucket.org/khinsen/"
- "domainfinder/downloads/DomainFinder-"
- version ".tar.gz"))
- (sha256
- (base32
- "1z26lsyf7xwnzwjvimmbla7ckipx6p734w7y0jk2a2fzci8fkdcr"))))
- (build-system python-build-system)
- (inputs
- (list python2-mmtk))
- (arguments
- `(#:python ,python-2
- ;; No test suite
- #:tests? #f))
- (home-page "http://dirac.cnrs-orleans.fr/DomainFinder.html")
- (synopsis "Analysis of dynamical domains in proteins")
- (description "DomainFinder is an interactive program for the determination
-and characterization of dynamical domains in proteins. It can infer dynamical
-domains by comparing two protein structures, or from normal mode analysis on a
-single structure. The software is currently not actively maintained and works
-only with Python 2 and NumPy < 1.9.")
- (license license:cecill-c)))
-
(define-public inchi
(package
(name "inchi")
@@ -332,69 +303,6 @@ with templates to facilitate the execution of the program. Input files can be
staged, and output files collected using a standard interface.")
(license license:bsd-3)))
-(define with-numpy-1.8
- (package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))
-
-(define-public nmoldyn
- (package
- (name "nmoldyn")
- (version "3.0.11")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/khinsen/nMOLDYN3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))
- (build-system python-build-system)
- (inputs
- (list (with-numpy-1.8 python2-matplotlib) python2-scientific netcdf
- gv))
- (propagated-inputs
- (list python2-mmtk))
- (arguments
- `(#:python ,python-2
- #:tests? #f ; No test suite
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'create-linux2-directory
- (lambda _
- (mkdir-p "nMOLDYN/linux2")))
- (add-before 'build 'change-PDF-viewer
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "nMOLDYN/Preferences.py"
- ;; Set the paths for external executables, substituting
- ;; gv for acroread.
- ;; There is also vmd_path, but VMD is not free software
- ;; and Guix contains currently no free molecular viewer that
- ;; could be substituted.
- (("PREFERENCES\\['acroread_path'\\] = ''")
- (format #f "PREFERENCES['acroread_path'] = '~a'"
- (which "gv")))
- (("PREFERENCES\\['ncdump_path'\\] = ''")
- (format #f "PREFERENCES['ncdump_path'] = '~a'"
- (which "ncdump")))
- (("PREFERENCES\\['ncgen_path'\\] = ''")
- (format #f "PREFERENCES['ncgen_path'] = '~a'"
- (which "ncgen3")))
- (("PREFERENCES\\['task_manager_path'\\] = ''")
- (format #f "PREFERENCES['task_manager_path'] = '~a'"
- (which "task_manager")))
- ;; Show documentation as PDF
- (("PREFERENCES\\['documentation_style'\\] = 'html'")
- "PREFERENCES['documentation_style'] = 'pdf'") ))))))
- (home-page "http://dirac.cnrs-orleans.fr/nMOLDYN.html")
- (synopsis "Analysis software for Molecular Dynamics trajectories")
- (description "nMOLDYN is an interactive analysis program for Molecular Dynamics
-simulations. It is especially designed for the computation and decomposition of
-neutron scattering spectra, but also computes other quantities. The software
-is currently not actively maintained and works only with Python 2 and
-NumPy < 1.9.")
- (license license:cecill)))
-
(define-public tng
(package
(name "tng")