summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-19 13:06:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-19 13:06:23 +0200
commit80194d9e47f9f50602a5a97ecd33fb9a95dfe03d (patch)
tree83926ef75b99a42e1beefd33d46e9019df44e960 /gnu/packages/commencement.scm
parentbc5654af82a187d1f8b47c2740b54a1e0e96258b (diff)
gnu: python-boot0: Don't install tests.
* gnu/packages/commencement.scm (python-boot0)[arguments]: Add phase to remove installed tests.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 3631a93fb5..22c76e16d2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3125,6 +3125,13 @@ memoized as a function of '%current-system'."
;; Prevent the 'ossaudiodev' extension from being
;; built, since it requires Linux headers.
(("'linux', ") ""))))
+ (add-after 'install 'remove-tests
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor version)
+ "/test"))))
,@(if (hurd-system?)
`((add-before 'build 'fix-regen
(lambda* (#:key inputs #:allow-other-keys)