summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-29 15:05:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-29 15:27:20 +0100
commit5bed6a31eddc0db153643007b58ec823b0b1ce64 (patch)
tree2252e4e60f023e406657ac2d7c8d1f24c3f4fc7e /gnu/packages/cran.scm
parent36ce2eb23c14fd3a8a6191fd7226d863fe094345 (diff)
gnu: Add r-timechange.
* gnu/packages/cran.scm (r-timechange): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9462f96e66..fea0d73649 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5937,6 +5937,31 @@ techniques from R packages and provides a common interface for calling the
methods.")
(license license:gpl3)))
+(define-public r-timechange
+ (package
+ (name "r-timechange")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "timechange" version))
+ (sha256
+ (base32
+ "0w3zbmzhg3zr5d9aa83kmr6gyhk75l7jysa7zs0pnz9x4ffr20w5"))))
+ (properties `((upstream-name . "timechange")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cpp11))
+ (home-page "https://github.com/vspinu/timechange/")
+ (synopsis "Efficient manipulation of Date-Times")
+ (description
+ "This package provides efficient routines for manipulation of
+date-time objects while accounting for time-zones and daylight saving
+times. The package includes utilities for updating of date-time
+components (year, month, day etc.), modification of time-zones,
+rounding of date-times, period addition and subtraction etc. Parts of
+the CCTZ source code, released under the Apache 2.0 License, are
+included in this package.")
+ (license license:gpl3)))
+
(define-public r-timedate
(package
(name "r-timedate")