summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 13:40:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:56 +0200
commit179900942d3ad6f26947c570421a71b8666124db (patch)
tree1fb5279ad1a4cedfcb94ed9c84d9a951521e3019 /gnu/packages/crates-io.scm
parentf540aa0e76b124b4658f6d33222f031ca5c528d6 (diff)
gnu: rust-botan: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-botan-0.10, rust-botan-0.8, rust-botan-sys-0.10, rust-botan-sys-0.8, rust-botan-src-0.21903, rust-botan-src-0.21703): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. * gnu/local.mk (GNU_SYSTEM_MODULES): Register new file. Change-Id: I459c94e9f70a51bdf48020792562e57ebc2119df
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm115
1 files changed, 1 insertions, 114 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b964333984..712341a101 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crates-apple)
+ #:use-module (gnu packages crates-crypto)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crates-gtk)
#:use-module (gnu packages crates-tls)
@@ -8103,120 +8104,6 @@ comes with a strict specification.")
(description "This crate implements schema generator for @code{borsh}.")
(license license:asl2.0)))
-(define-public rust-botan-0.10
- (package
- (name "rust-botan")
- (version "0.10.3")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1vzl5pdysh848zpphsgvj9c40zdi3ynl32zzixsd8vg4vaflhb49"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-botan-sys" ,rust-botan-sys-0.10))
- #:cargo-development-inputs
- (("rust-hex" ,rust-hex-0.4)
- ("rust-wycheproof" ,rust-wycheproof-0.5))))
- (inputs (list botan))
- (home-page "https://botan.randombit.net/")
- (synopsis "Rust wrapper for Botan cryptography library")
- (description "Rust wrapper for Botan cryptography library")
- (license license:expat)))
-
-(define-public rust-botan-0.8
- (package
- (inherit rust-botan-0.10)
- (name "rust-botan")
- (version "0.8.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "08bmiyn7c3b0dgx20w6hr28d9jcq7cj78cchr84pc686sb2s41ik"))))
- (arguments
- `(#:cargo-inputs
- (("rust-botan-sys" ,rust-botan-sys-0.8)
- ("rust-cstr-core" ,rust-cstr-core-0.2)
- ("rust-cty" ,rust-cty-0.2))))))
-
-(define-public rust-botan-sys-0.10
- (package
- (name "rust-botan-sys")
- (version "0.10.3")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-sys" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1cbjr44gc5dhmgl43sfiqzbsma4anfi3h26m4yzsli23yd1lmyf8"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-botan-src" ,rust-botan-src-0.21903))))
- (inputs (list botan))
- (home-page "https://botan.randombit.net/")
- (synopsis "FFI wrapper for Botan cryptography library")
- (description "FFI wrapper for Botan cryptography library")
- (license license:expat)))
-
-(define-public rust-botan-sys-0.8
- (package
- (inherit rust-botan-sys-0.10)
- (name "rust-botan-sys")
- (version "0.8.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-sys" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1m11zblxfanrhl97j7z3ap7n17rr8j0rg91sr7f9j6y2bsniaz1x"))))
- (arguments
- `(#:cargo-inputs
- (("rust-botan-src" ,rust-botan-src-0.21703)
- ("rust-cty" ,rust-cty-0.2))))))
-
-(define-public rust-botan-src-0.21903
- (package
- (name "rust-botan-src")
- (version "0.21903.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-src" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "19fhll4g0v8hbyjxg8c790l9ln5xgf4r6xdcnw438mpy81hvrdxy"))
- (modules '((guix build utils)))
- (snippet
- '(begin (delete-file-recursively "botan")))))
- (build-system cargo-build-system)
- (arguments '(#:skip-build? #t))
- (home-page "https://botan.randombit.net/")
- (synopsis "Sources of Botan cryptography library")
- (description "Sources of Botan cryptography library")
- (license license:expat)))
-
-(define-public rust-botan-src-0.21703
- (package
- (inherit rust-botan-src-0.21903)
- (name "rust-botan-src")
- (version "0.21703.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-src" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0s2ad9q84qsrllfsbj7hjhn7gr3hab9ng6lwzwqmimia6yvja8y8"))
- (modules '((guix build utils)))
- (snippet
- '(begin (delete-file-recursively "botan")))))))
-
(define-public rust-boxfnonce-0.1
(package
(name "rust-boxfnonce")