summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-17 21:14:29 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 00:09:02 +0200
commit8c06526634b365fd1e9a78b3039a76c639c7abc7 (patch)
treec27d6c0f354cc8758166793552a4d16d3a821f4f /gnu/packages/crates-io.scm
parent3d06823e6b214b2f047870d5cecb4da649b3048d (diff)
gnu: rust-inventory: Add 0.2.3.
* gnu/packages/crates-io.scm (rust-inventory-0.2): New variable. (rust-inventory-0.1): Inherit from it.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 30 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e73269663e..ed2fe3c487 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29417,8 +29417,37 @@ primitive Rust types.")
immutable interval tree.")
(license license:expat)))
+(define-public rust-inventory-0.2
+ (package
+ (name "rust-inventory")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "inventory" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "06h9xw67wx18rank4yyz93iq89j0fk6fbazryfvf5ach1dp4qd44"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ctor" ,rust-ctor-0.1)
+ ("rust-ghost" ,rust-ghost-0.1))
+ #:cargo-development-inputs
+ (("rust-rustversion" ,rust-rustversion-1)
+ ("rust-trybuild" ,rust-trybuild-1))))
+ (home-page "https://github.com/dtolnay/inventory")
+ (synopsis "Typed distributed plugin registration")
+ (description
+ "This package provides a way to set up a plugin registry into which
+plugins can be registered from any source file linked into your program.
+There does not need to be a central list of all the plugins.")
+ ;; Either license can be chosen at the users option.
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-inventory-0.1
(package
+ (inherit rust-inventory-0.2)
(name "rust-inventory")
(version "0.1.11")
(source
@@ -29428,21 +29457,12 @@ immutable interval tree.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1m1zdjgs3nzfdxf86mc1i0id56fvk8rfw63rf04yi88bqrh53szh"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
(("rust-ctor" ,rust-ctor-0.1)
("rust-ghost" ,rust-ghost-0.1)
- ("rust-inventory-impl" ,rust-inventory-impl-0.1))))
- (home-page "https://github.com/dtolnay/inventory")
- (synopsis "Typed distributed plugin registration")
- (description
- "This package provides a way to set up a plugin registry into which
-plugins can be registered from any source file linked into your program.
-There does not need to be a central list of all the plugins.")
- ;; Either license can be chosen at the users option.
- (license (list license:expat license:asl2.0))))
+ ("rust-inventory-impl" ,rust-inventory-impl-0.1))))))
(define-public rust-inventory-impl-0.1
(package