summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorAndrew Jose <arnav.jose@gmail.com>2023-09-21 18:14:48 +0530
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 21:17:18 +0300
commitdd77ec804f5f02d06fe60b3da527e0812bfb45b7 (patch)
tree3243642c88ed1820b570f1d886f8c8d8cc956a4b /gnu/packages/crates-io.scm
parent5ede6e866135b1c7e16fd4bb07ff123db2b88d74 (diff)
gnu: Add rust-snafu-derive-0.7.
* gnu/packages/crates-io.scm (rust-snafu-derive-0.7): New variable. (rust-snafu-derive-0.6): Inherit from rust-snafu-derive-0.7. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ab29c86989..8b67e23932 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -62820,8 +62820,33 @@ monotone matrix.")
clone.")
(license (list license:expat license:asl2.0))))
+(define-public rust-snafu-derive-0.7
+ (package
+ (name "rust-snafu-derive")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "snafu-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gzy9rzggs090zf7hfvgp4lm1glrmg9qzh796686jnq7bxk7j04r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-heck" ,rust-heck-0.4)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/shepmaster/snafu")
+ (synopsis "Ergonomic error handling library")
+ (description "Snafu aims to be an ergonomic error handling library. This
+package provides derive macros.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-snafu-derive-0.6
(package
+ (inherit rust-snafu-derive-0.7)
(name "rust-snafu-derive")
(version "0.6.10")
(source
@@ -62831,17 +62856,11 @@ clone.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0nri7ma06g5kimpcdcm8359a55nmps5f3kcngy0j6bin7jhfy20m"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
- (home-page "https://github.com/shepmaster/snafu")
- (synopsis "Ergonomic error handling library")
- (description "Snafu aims to be an ergonomic error handling library. This
-package provides derive macros.")
- (license (list license:expat license:asl2.0))))
+ ("rust-syn" ,rust-syn-1))))))
(define-public rust-snafu-0.6
(package