summaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/dlang.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 9a972182cc..15680cb079 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Esther Flashner <esther@flashner.co.il>
@@ -149,14 +149,14 @@ to a minimal test case.")
(define ldc-bootstrap
(package
(name "ldc")
- (version "1.27.1")
+ (version "1.30.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ldc-developers/ldc/releases"
"/download/v" version "/ldc-" version "-src.tar.gz"))
(sha256
- (base32 "1775001ba6n8w46ln530kb5r66vs935ingnppgddq8wqnc0gbj4k"))))
+ (base32 "1kfs4fpr1525sv2ny10hlfppy8c075vjm8m649wr2b9411pkgfzx"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;skip in the bootstrap
@@ -190,10 +190,7 @@ to a minimal test case.")
("tzdata" ,tzdata)
("zlib" ,zlib)))
(native-inputs
- ;; Importing (gnu packages commencement) would introduce a cycle.
- `(("ld-gold-wrapper" ,(module-ref (resolve-interface
- '(gnu packages commencement))
- 'ld-gold-wrapper))
+ `(("lld-wrapper" ,(make-lld-wrapper lld-11 #:lld-as-ld? #t))
("llvm" ,llvm-11)
("ldc" ,gdmd)
("ninja" ,ninja)
@@ -260,7 +257,7 @@ bootstrapping more recent compilers written in D.")
;; find the compiler-rt libraries they need to be linked with
;; for the tests.
(substitute* (find-files "." "^ldc2.*\\.conf\\.in$")
- ((".*lib-dirs = \\[\n" all)
+ ((".*LIB_SUFFIX.*" all)
(string-append all
" \"" clang-runtime
"/lib/linux\",\n"))))))
@@ -294,12 +291,15 @@ bootstrapping more recent compilers written in D.")
""))
;; The GDB tests suite fails; there are a few bug reports about
;; it upstream.
- (for-each delete-file (find-files "tests" "gdb.*\\.(d|sh)$"))
+ (for-each delete-file (find-files "tests" "gdb.*\\.(c|d|sh)$"))
(delete-file "tests/d2/dmd-testsuite/runnable/debug_info.d")
(delete-file "tests/d2/dmd-testsuite/runnable/b18504.d")
(substitute* "runtime/druntime/test/exceptions/Makefile"
((".*TESTS\\+=rt_trap_exceptions_drt_gdb.*")
""))
+ ;; Drop gdb_dflags from the test suite.
+ (substitute* "tests/d2/CMakeLists.txt"
+ (("\\$\\{gdb_dflags\\}") ""))
;; The following tests fail on some systems, not all of
;; which are tested upstream.
(with-directory-excursion "tests"
@@ -346,7 +346,8 @@ bootstrapping more recent compilers written in D.")
(invoke "ctest" "--output-on-failure" "-j" job-count
"-R" "lit-tests")
(display "running the dmd test suite...\n")
- (invoke "ctest" "--output-on-failure" "-j" job-count
+ ;; This test has a race condition so run it with 1 core.
+ (invoke "ctest" "--output-on-failure" "-j" "1"
"-R" "dmd-testsuite")
(display "running the defaultlib unit tests and druntime \
integration tests...\n")
@@ -412,27 +413,27 @@ needed.")
(define-public gtkd
(package
(name "gtkd")
- (version "3.9.0")
+ (version "3.10.0")
(source
(origin
(method url-fetch/zipbomb)
(uri (string-append "https://gtkd.org/Downloads/sources/GtkD-"
version ".zip"))
(sha256
- (base32 "0qv8qlpwwb1d078pnrf0a59vpbkziyf53cf9p6m8ms542wbcxllp"))))
+ (base32 "0vc5ssb3ar02mg2pngmdi1xg4qjaya8332a9mk0sv97x6b4ddy3g"))))
(build-system gnu-build-system)
(native-inputs
- `(("unzip" ,unzip)
- ("ldc" ,ldc)
- ("pkg-config" ,pkg-config)
- ("xorg-server-for-tests" ,xorg-server-for-tests)))
+ (list unzip
+ ldc
+ pkg-config
+ xorg-server-for-tests))
(arguments
`(#:test-target "test"
#:make-flags
`("DC=ldc2"
,(string-append "prefix=" (assoc-ref %outputs "out"))
- ,(string-append "libdir=" (assoc-ref %outputs "out")
- "/lib"))
+ ,(string-append "libdir=" (assoc-ref %outputs "out") "/lib")
+ "pkgconfigdir=lib/pkgconfig")
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -443,13 +444,12 @@ needed.")
(("default-goal: libs test") "default-goal: libs")
(("all: libs shared-libs test") "all: libs shared-libs")
;; Work around upstream bug.
- (("\\$\\(prefix\\)\\/\\$\\(libdir\\)") "$(libdir)"))
- #t))
- (add-before 'check 'prepare-x
+ (("\\$\\(prefix\\)\\/\\$\\(libdir\\)") "$(libdir)"))))
+ (add-before 'check 'pre-check
(lambda _
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
- #t)))))
+ (setenv "CC" ,(cc-for-target)))))))
(home-page "https://gtkd.org/")
(synopsis "D binding and OO wrapper of GTK+")
(description "This package provides bindings to GTK+ for D.")