summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
commitd9dee5ea2f564fa6979ae552fd9bd5ac22f86ecc (patch)
tree8d1b2f89808f9e7ddbeddeab7563f3ab82e533cd /gnu/packages/geo.scm
parentef4e4c9a2ccc1678182fa6e4409fff13c669fd14 (diff)
parent3de361d9c9d320aefbd43710124d7b07af891de1 (diff)
Merge branch 'master' into mesa-updates
Change-Id: I0b92a95109688a1a4c50572bc25a4e5676e0921e
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 31abb2cc36..73b7aa3d11 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3228,3 +3228,31 @@ For maps, it can uses its own \"binfile\" map format, or Garmin map
file format, and data from OpenStreetMap, Garmin maps, Marco Polo
Grosser Reiseplaner, Routeplaner Europa 2007, Map + Route.")
(license license:gpl2)))
+
+(define-public laszip
+ (package
+ (name "laszip")
+ (version "3.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LASzip/LASzip")
+ (commit "3.4.3")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09lcsgxwv0jq50fhsgfhx0npbf1zcwn3hbnq6q78fshqksbxmz7m"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DLASZIP_BUILD_STATIC=NO")
+ #:build-type "Release"
+ ;; No tests.
+ #:tests? #f))
+ (home-page "https://laszip.org/")
+ (synopsis "Compression library for LAS files")
+ (description
+ "LASzip is a library for compressing @code{LAS} files and uncompressing
+@code{LAZ} files. The @code{LAS} format is a file format designed for the
+interchange and archiving of lidar point cloud data.")
+ (license license:asl2.0)))