summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:59 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:17 -0500
commit80f52867abde1ba7ed4831fe5d489c9cd0be862f (patch)
treef26de74d11bfad54d97aab4a0fa7d1aa4c219346 /gnu/packages/golang-web.scm
parentf1fab4912270bcc81890d7e9d8f55ce54915be1d (diff)
gnu: go-github-com-gorilla-csrf: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-csrf): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I77bcbdaf515152b95418f9e2632d810202a1e23a
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8ced6a4c6f..5be08caf2e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -144,6 +144,32 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-gorilla-csrf
+ (package
+ (name "go-github-com-gorilla-csrf")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/csrf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iryq0z48yi7crfbd8jxyn7lh1gsglpiglvjgnf23bz6xfisssav"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("github.com/gorilla/securecookie" ,go-github-com-gorilla-securecookie)
+ ("github.com/pkg/errors" ,go-github-com-pkg-errors)))
+ (arguments
+ '(#:import-path "github.com/gorilla/csrf"))
+ (home-page "https://github.com/gorilla/csrf")
+ (synopsis "Cross Site Request Forgery (CSRF) prevention middleware")
+ (description
+ "Gorilla/csrf provides Cross Site Request Forgery (CSRF) prevention
+middleware for Go web applications and services.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-css
(package
(name "go-github-com-gorilla-css")