summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:28 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:05 +0000
commitc2f5510730696731ddf8c83d69d710ab7804d090 (patch)
tree1906f3dd341950450b95596f816afcadc3a292f3 /gnu/packages/gtk.scm
parentc3417f07546e9d5c7b1c3acb19d67b3b377d59fb (diff)
gnu: at-spi2-core: Remove trailing #t.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Remove trailing #t. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 634a0125d8..842a46a846 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -734,12 +734,11 @@ scaled, composited, modified, saved, or rendered.")
;; Ensure that the cross-references point to the "doc" output.
(substitute* "doc/libatspi/meson.build"
(("docpath =.*")
- (string-append "docpath = '" (assoc-ref outputs "doc") "/share/gtk-doc/html'\n")))
- #t))
+ (string-append "docpath = '" (assoc-ref outputs "doc")
+ "/share/gtk-doc/html'\n")))))
(add-before 'install 'prepare-doc-directory
(lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p (string-append (assoc-ref outputs "doc") "/share"))
- #t))
+ (mkdir-p (string-append (assoc-ref outputs "doc") "/share"))))
(add-after 'unpack 'patch-docbook-sgml
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(let* ((xmldoc
@@ -748,8 +747,7 @@ scaled, composited, modified, saved, or rendered.")
"/xml/dtd/docbook")))
(substitute* "doc/libatspi/libatspi-docs.sgml"
(("http://.*/docbookx\\.dtd")
- (string-append xmldoc "/docbookx.dtd")))
- #t)))
+ (string-append xmldoc "/docbookx.dtd"))))))
,@(if (%current-target-system)
'()
'((add-after 'install 'move-documentation
@@ -760,8 +758,7 @@ scaled, composited, modified, saved, or rendered.")
(string-append out "/share/gtk-doc")
(string-append doc "/share/gtk-doc"))
(delete-file-recursively
- (string-append out "/share/gtk-doc")))
- #t))))
+ (string-append out "/share/gtk-doc")))))))
(add-after 'install 'check
(lambda* (#:key tests? #:allow-other-keys)
(setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME