summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:58:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commit3657bd1faa16d8a074c8867b6d9bb550bd415858 (patch)
treea60745db27e47a2837ac0eff6ad25489f1f35a53 /gnu/packages/haskell.scm
parent2025964bbaf916d5b02418da7ce34430b4d3fcad (diff)
gnu: Add ghc-haskell-src-exts-util.
* gnu/packages/haskell.scm (ghc-haskell-src-exts-util): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b08a269de0..e9e46a30b2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1012,6 +1012,32 @@ are supported. Apart from these standard extensions, it also handles regular
patterns as per the HaRP extension as well as HSX-style embedded XML syntax.")
(license license:bsd-3)))
+(define-public ghc-haskell-src-exts-util
+ (package
+ (name "ghc-haskell-src-exts-util")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "haskell-src-exts-util/haskell-src-exts-util-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14rhwcrdz3kfb69c64qn8kybl7wnpajrjlfz5p95ca4bva4mwclg"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-data-default" ,ghc-data-default)
+ ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-uniplate" ,ghc-uniplate)))
+ (home-page "https://github.com/pepeiborra/haskell-src-exts-util")
+ (synopsis "Helper functions for working with haskell-src-exts trees")
+ (description
+ "This package provides helper functions for working with
+@code{haskell-src-exts} trees.")
+ (license license:bsd-3)))
+
(define-public hlint
(package
(name "hlint")