summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-03 21:57:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-04 09:51:40 +0200
commit9c098979a2ce5732d689ddf919aa9bd3464d9d3d (patch)
tree00dcdab64c9a4a57508568b86b3effa85b4fc99d /gnu/packages/image.scm
parent6f53d04c32404fd7454f24c33eea4051c3b9a0b9 (diff)
gnu: libavif: Honor #:tests? flag.
* gnu/packages/image.scm (libavif)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c7cfad8714..53e5363dcd 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2014, 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2020 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2020, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
@@ -2181,8 +2181,9 @@ This package can be used to create @code{favicon.ico} files for web sites.")
#:phases
#~(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "./aviftest" "../source/tests/data")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./aviftest" "../source/tests/data"))))
(add-after 'install 'install-readme
(lambda _
(let ((doc (string-append #$output "/share/doc/libavif-" #$version)))