summaryrefslogtreecommitdiff
path: root/gnu/packages/iso-codes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/iso-codes.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/iso-codes.scm')
-rw-r--r--gnu/packages/iso-codes.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
index b2cfd3434c..f8775c5eaa 100644
--- a/gnu/packages/iso-codes.scm
+++ b/gnu/packages/iso-codes.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,7 +29,9 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages python))
-(define-public iso-codes
+(define-public iso-codes/official
+ ;; This package variant is intended for ‘external’ use, such as users running
+ ;; ‘guix install’, where any deviation from ISO gospel might be harmful.
(package
(name "iso-codes")
(version "4.5.0")
@@ -77,6 +79,25 @@ changes in the ISO standard and will not work with outdated
information.")
(license license:gpl2+))) ; some bits use the lgpl2
+(define-public iso-codes
+ ;; This package should be used universally within Guix, e.g., as an input to
+ ;; other Guix packages or in the Guix System installer's country selector.
+ (hidden-package
+ (package
+ (inherit iso-codes/official)
+ (source
+ (origin
+ (inherit (package-source iso-codes/official))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* (find-files "." "\\.po$")
+ (("#.*Name for TWN,.*") "")
+ (("^msgid \"Taiwan, .*") "# Guix doesn't use "))
+ (substitute* "data/iso_3166-1.json"
+ (("(Taiwan), [^\"]*" _ name) name))))))
+ (synopsis "Various ISO standards as used by GNU@tie{}Guix"))))
+
(define-public python-iso639
(package
(name "python-iso639")
@@ -96,9 +117,6 @@ that is concerned with representation of names for languages and language
groups.")
(license license:agpl3+)))
-(define-public python2-iso639
- (package-with-python2 python-iso639))
-
(define-public python-iso3166
(package
(name "python-iso3166")
@@ -115,6 +133,3 @@ groups.")
(synopsis "Self-contained ISO 3166-1 country definitions")
(description "This package provides the ISO 3166-1 country definitions.")
(license license:expat)))
-
-(define-public python2-iso3166
- (package-with-python2 python-iso3166))