summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-09-14 22:35:04 -0400
committerLeo Famulari <leo@famulari.name>2023-07-23 22:26:00 -0400
commitabf7a1e986f93f8fade230ae6f95b04cc998041b (patch)
tree6f59dff54a0ac27b28c80138d21ed95e25e01453 /gnu/packages/linux.scm
parent9ecc29394ee2ceb1da643dc12f2b18b9adbda706 (diff)
gnu: Add linux-libre 6.5.
* gnu/packages/linux.scm (linux-libre-6.5-version, linux-libre-6.5-gnu-revision, deblob-scripts-6.5, linux-libre-6.5-pristine-source, linux-libre-6.5-source, linux-libre-headers-6.5, linux-libre-6.5): New variables. * gnu/packages/aux-files/linux-libre/6.5-arm.conf, gnu/packages/aux-files/linux-libre/6.5-arm64.conf, gnu/packages/aux-files/linux-libre/6.5-i686.conf, gnu/packages/aux-files/linux-libre/6.5-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c6fceaf81c..a3f74cd253 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -492,6 +492,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-6.5-version "6.5.5")
+(define-public linux-libre-6.5-gnu-revision "gnu")
+(define deblob-scripts-6.5
+ (linux-libre-deblob-scripts
+ linux-libre-6.5-version
+ linux-libre-6.5-gnu-revision
+ (base32 "01mm6v67bcrhgm97axsw46x0iix9im7hmlb765f3bkjhwklpxdy7")
+ (base32 "132ps1jprxw6kqyscsar38fn7s12kg416mfhz7w702f4ajgq1ndi")))
+(define-public linux-libre-6.5-pristine-source
+ (let ((version linux-libre-6.5-version)
+ (hash (base32 "15gg8sb6cfgk1afwj7fl7mj4nkj14w43vzwvw0qsg3nzyxwh7wcc")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.5)))
+
(define-public linux-libre-6.4-version "6.4.16")
(define-public linux-libre-6.4-gnu-revision "gnu")
(define deblob-scripts-6.4
@@ -628,6 +643,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.5-source
+ (source-with-patches linux-libre-6.5-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.4-source
(source-with-patches linux-libre-6.4-pristine-source
(list %boot-logo-patch
@@ -747,6 +767,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.5
+ (make-linux-libre-headers* linux-libre-6.5-version
+ linux-libre-6.5-gnu-revision
+ linux-libre-6.5-source))
+
(define-public linux-libre-headers-6.4
(make-linux-libre-headers* linux-libre-6.4-version
linux-libre-6.4-gnu-revision
@@ -1091,6 +1116,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.5
+ (make-linux-libre* linux-libre-6.5-version
+ linux-libre-6.5-gnu-revision
+ linux-libre-6.5-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.4
(make-linux-libre* linux-libre-6.4-version
linux-libre-6.4-gnu-revision