summaryrefslogtreecommitdiff
path: root/gnu/packages/lirc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/lirc.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/lirc.scm')
-rw-r--r--gnu/packages/lirc.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
index 1b8e8e37bd..5c89e83d7c 100644
--- a/gnu/packages/lirc.scm
+++ b/gnu/packages/lirc.scm
@@ -133,17 +133,4 @@ on just one button press.")
(home-page "https://github.com/tompreston/python-lirc")
(synopsis "Python bindings for LIRC")
(description "@code{lirc} is a Python module which provides LIRC bindings.")
- (license license:gpl3)
- (properties `((python2-variant . ,(delay python2-lirc)))))))
-
- (define-public python2-lirc
- (let ((base (package-with-python2 (strip-python2-variant python-lirc))))
- (package/inherit base
- (arguments
- `(#:tests? #f ; the only tests that exist are human-interactive
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'build-from-cython-files
- (lambda _ (invoke "make" "py2"))))))
- (native-inputs
- `(("python2-cython" ,python2-cython))))))
+ (license license:gpl3))))