summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:02:42 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:42 +0100
commitbccd84ba0dd7b44242c0f7e7729717c2dac36f81 (patch)
tree051b86077c02b496a6d42160ac5a3d652cc3c4f8 /gnu/packages/ocaml.scm
parent5d1809a08a0bf048341aff3d6a6e4234bd607dca (diff)
gnu: Remove ocaml4.07-ppx-optcomp.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-optcomp): Remove variable. (ocaml-ppx-optcomp)[properties]: Remove variant. Change-Id: I030cadf5a90d8386b892d2318244f997fc55283c
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d961bb7ec7..ceb1c80506 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7260,25 +7260,13 @@ else expression.")
(build-system dune-build-system)
(propagated-inputs
(list ocaml-base ocaml-stdio ocaml-ppxlib))
- (properties `((upstream-name . "ppx_optcomp")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-optcomp))))
+ (properties `((upstream-name . "ppx_optcomp")))
(synopsis "Optional compilation for OCaml")
(description "Ppx_optcomp stands for Optional Compilation. It is a tool
used to handle optional compilations of pieces of code depending of the word
size, the version of the compiler, ...")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-optcomp
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-optcomp)
- (version "0.11.0")
- (source
- (janestreet-origin
- "ppx_optcomp" version
- "1bb52p2j2h4s9f06vrcpla80rj93jinnzq6jzilapyx9q068929i"))
- (properties `((upstream-name . "ppx_optcomp"))))))
-
(define-public ocaml-ppx-let
(package
(name "ocaml-ppx-let")