summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fltk-shared-lib-defines.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-10 17:50:27 -0400
committerMark H Weaver <mhw@netris.org>2015-06-10 17:50:27 -0400
commit14928016556300a6763334d4279c3d117902caaf (patch)
treed0dc262b14164b82f97dd6e896ca9e93a1fabeea /gnu/packages/patches/fltk-shared-lib-defines.patch
parent1511e0235525358abb52cf62abeb9457605b5093 (diff)
parent57cd353d87d6e9e6e882327be70b4d7b5ce863ba (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/fltk-shared-lib-defines.patch')
-rw-r--r--gnu/packages/patches/fltk-shared-lib-defines.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/fltk-shared-lib-defines.patch b/gnu/packages/patches/fltk-shared-lib-defines.patch
new file mode 100644
index 0000000000..d36a50ff5e
--- /dev/null
+++ b/gnu/packages/patches/fltk-shared-lib-defines.patch
@@ -0,0 +1,51 @@
+This patch from upstream revision 10588.
+
+--- fltk-1.3.3/src/Xutf8.h
++++ fltk-1.3.3/src/Xutf8.h
+@@ -25,6 +25,7 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xlocale.h>
+ #include <X11/Xutil.h>
++#include <FL/Fl_Export.H>
+
+ typedef struct {
+ int nb_font;
+@@ -98,8 +99,8 @@
+ XUtf8FontStruct *font_set,
+ unsigned int ucs);
+
+-int
+-XGetUtf8FontAndGlyph(
++FL_EXPORT int
++fl_XGetUtf8FontAndGlyph(
+ XUtf8FontStruct *font_set,
+ unsigned int ucs,
+ XFontStruct **fnt,
+--- fltk-1.3.3/src/gl_draw.cxx
++++ fltk-1.3.3/src/gl_draw.cxx
+@@ -114,7 +114,7 @@
+ for (int i = 0; i < 0x400; i++) {
+ XFontStruct *font = NULL;
+ unsigned short id;
+- XGetUtf8FontAndGlyph(gl_fontsize->font, ii, &font, &id);
++ fl_XGetUtf8FontAndGlyph(gl_fontsize->font, ii, &font, &id);
+ if (font) glXUseXFont(font->fid, id, 1, gl_fontsize->listbase+ii);
+ ii++;
+ }
+--- fltk-1.3.3/src/xutf8/utf8Wrap.c
++++ fltk-1.3.3/src/xutf8/utf8Wrap.c
+@@ -816,10 +816,10 @@
+ /** get the X font and glyph ID of a UCS char **/
+ /*****************************************************************************/
+ int
+-XGetUtf8FontAndGlyph(XUtf8FontStruct *font_set,
+- unsigned int ucs,
+- XFontStruct **fnt,
+- unsigned short *id) {
++fl_XGetUtf8FontAndGlyph(XUtf8FontStruct *font_set,
++ unsigned int ucs,
++ XFontStruct **fnt,
++ unsigned short *id) {
+
+ /* int x; */
+ int *encodings; /* encodings array */