summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libwmf-CAN-2004-0941.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-08 10:59:39 -0400
committerMark H Weaver <mhw@netris.org>2015-10-08 10:59:39 -0400
commitb81378251c629615aff0d62ca686bb53a10367de (patch)
tree4c15f2be58d665cf0eed1e00c84f70764890c3b8 /gnu/packages/patches/libwmf-CAN-2004-0941.patch
parent319fe79dd01e03c4ef61311c336bcd77e1133f02 (diff)
parentb5881775ac2db345bf5826d6351366346ff03275 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/libwmf-CAN-2004-0941.patch')
-rw-r--r--gnu/packages/patches/libwmf-CAN-2004-0941.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/libwmf-CAN-2004-0941.patch b/gnu/packages/patches/libwmf-CAN-2004-0941.patch
new file mode 100644
index 0000000000..84dd9baee6
--- /dev/null
+++ b/gnu/packages/patches/libwmf-CAN-2004-0941.patch
@@ -0,0 +1,21 @@
+Copied from Fedora.
+
+http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CAN-2004-0941.patch
+
+--- libwmf-0.2.8.4/src/extra/gd/gd_png.c 2004-11-11 14:02:37.407589824 -0500
++++ libwmf-0.2.8.4/src/extra/gd/gd_png.c 2004-11-11 14:04:29.672522960 -0500
+@@ -188,6 +188,14 @@
+
+ png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
+ &interlace_type, NULL, NULL);
++ if (overflow2(sizeof (int), width))
++ {
++ return NULL;
++ }
++ if (overflow2(sizeof (int) * width, height))
++ {
++ return NULL;
++ }
+ if ((color_type == PNG_COLOR_TYPE_RGB) ||
+ (color_type == PNG_COLOR_TYPE_RGB_ALPHA))
+ {