summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/webkitgtk-bind-all-fonts.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-01 23:03:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-12 23:18:12 -0400
commit4ec7aac483e882d4c93a01e97a4ab502a2abf7b3 (patch)
tree90b806d19ffde887da751ac1b1f53f05b3e26728 /gnu/packages/patches/webkitgtk-bind-all-fonts.patch
parent322e23e600deb84581c4e1c709320ad94e3aa660 (diff)
gnu: webkitgtk: Update to 2.36.0 and enable extra features.
* gnu/packages/webkit.scm (webkitgtk): Update to 2.36.0. [source]: Remove the webkitgtk-bind-all-fonts.patch and webkitgtk-canonicalize-paths.patch patches. [arguments]: Use gexp. [tests?]: Update comment. [build-type]: Add explanatory comment. [configure-flags]: Enable gamepad support, remove nonexistent USE_SYSTEMD option and enable mini-browser. [phases]{do-not-disable-new-dtags}: New phase. {help-cmake-find-elogind}: Likewise. {patch-gtk-doc-scan}: Simplify to avoid for-each. Locate docbookx.dtd via search-input-file. {embed-absolute-wpebackend-reference}: Use search-input-file. [native-inputs]: Use new style. [inputs]: Likewise. Add elogind and libmanette. [description]: Adjust indentation. (webkitgtk-with-libsoup2): Re-format comment, fixing spacing. [configure-flags]: Use gexp. [propagated-inputs]: Use modify-inputs to replace libsoup with libsoup-minimal-2. * gnu/packages/patches/webkitgtk-bind-all-fonts.patch: Delete file. * gnu/packages/patches/webkitgtk-canonicalize-paths.patch: Likewise. * gnu/local.mk: De-register them.
Diffstat (limited to 'gnu/packages/patches/webkitgtk-bind-all-fonts.patch')
-rw-r--r--gnu/packages/patches/webkitgtk-bind-all-fonts.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/webkitgtk-bind-all-fonts.patch b/gnu/packages/patches/webkitgtk-bind-all-fonts.patch
deleted file mode 100644
index 27013180c4..0000000000
--- a/gnu/packages/patches/webkitgtk-bind-all-fonts.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Upstream commit: https://github.com/WebKit/WebKit/commit/31ac354cbeecf866f9a38f7b2f8f59f7975d3f6a
-
-diff --git a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
-index ecc804663784..8de174be3c0e 100644
---- a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
-+++ b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
-@@ -288,6 +288,7 @@ static void bindFonts(Vector<CString>& args)
- const char* homeDir = g_get_home_dir();
- const char* dataDir = g_get_user_data_dir();
- const char* cacheDir = g_get_user_cache_dir();
-+ const char* const * dataDirs = g_get_system_data_dirs();
-
- // Configs can include custom dirs but then we have to parse them...
- GUniquePtr<char> fontConfig(g_build_filename(configDir, "fontconfig", nullptr));
-@@ -304,6 +305,10 @@ static void bindFonts(Vector<CString>& args)
- bindIfExists(args, fontHomeConfigDir.get());
- bindIfExists(args, fontData.get());
- bindIfExists(args, fontHomeData.get());
-+ for (auto* dataDir = dataDirs; dataDir && *dataDir; dataDir++) {
-+ GUniquePtr<char> fontDataDir(g_build_filename(*dataDir, "fonts", nullptr));
-+ bindIfExists(args, fontDataDir.get());
-+ }
- bindIfExists(args, "/var/cache/fontconfig"); // Used by Debian.
- }
-