summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/perl.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ba65cc6e6d..1f947b48fa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10020,6 +10020,13 @@ the job on behalf of @code{Term::Size::Any}.")
"Term-Size-Perl-" version ".tar.gz"))
(sha256
(base32 "17i05y186l977bhp32b24c8rqasmg1la934dizf5sc0vrd36g6mf"))))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'remove-timestamps
+ ;; Remove timestamp in comment for reproducible builds
+ (lambda _
+ (substitute* "inc/Probe.pm"
+ ((". created ...scalar localtime..") "")))))))
(build-system perl-build-system)
(home-page "https://metacpan.org/release/Term-Size-Perl")
(synopsis "Perl extension for retrieving terminal size (Perl version)")
@@ -11849,3 +11856,27 @@ regexp patterns in modules.")
(description "Data::SExpression parses Lisp S-Expressions into Perl data
structures.")
(license license:perl-license)))
+
+(define-public perl-socket-msghdr
+ (package
+ (name "perl-socket-msghdr")
+ (version "0.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/F/FE/FELIPE/Socket-MsgHdr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0g3qa7xn0aqn417jfvnc0i3ksyqa7bnvws0wihldir6ywcaiql4n"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Socket-MsgHdr")
+ (synopsis "Perform advanced operations via sendmsg and recvmsg")
+ (description "Socket::MsgHdr provides advanced socket messaging operations
+via sendmsg and recvmsg.
+
+It also allows manipulating ancillary data or so-called control
+information (cmsghdr). This ancillary data may be used for file descriptor
+passing, IPv6 operations, and a host of implemenation-specific extensions.")
+ (license license:perl-license)))