summaryrefslogtreecommitdiff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-26 11:12:59 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-26 11:12:59 -0500
commitd15ffea6f47a40a9d36f3f32935e63f92e90af03 (patch)
tree826b3be17acf0f680e7888b3f7a3eeeaaedded7d /gnu/packages/potassco.scm
parent8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a (diff)
parent176440c056fdde6da98b11720989b1ed060ec97c (diff)
Merge branch 'master' into mesa-updates
Change-Id: Ide02272218e76dfae6dc9f8748871c8d61704260
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index e6d7caa1ef..887c220ccf 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -221,6 +221,28 @@ satisfiability checking (SAT).")
(description "Clingo computes answer sets for a given logic program.")
(license license:expat)))
+(define-public clingo-dl
+ (package
+ (name "clingo-dl")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clingo-dl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dncwj63vdm6958vb7355d5j9mdr7hm037j4z82yz6l77jg3sipw"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f ; no tests
+ #:configure-flags #~`("-DPYCLINGODL_ENABLE=off")))
+ (inputs (list clingo))
+ (home-page "https://github.com/potassco/clingo-dl")
+ (synopsis "Solver for answer set programs modulo difference constraints")
+ (description "Clingo-DL is an extension to Clingo that models constraints
+over difference logic.")
+ (license license:expat)))
+
(define-public emacs-pasp-mode
(let ((commit "59385eb0e8ebcfc8c11dd811fb145d4b0fa3cc92")
(revision "1"))