summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:42:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:44 -0400
commit52abcbbdc03177f70b4a09946265866f402b1375 (patch)
tree1c560fc557980c89ac70df18c8d15d8d30e88492 /gnu/packages/python-xyz.scm
parent2644fac20ee5bc7370186fadbd021b2395ca11b2 (diff)
gnu: Remove python2-quex-0.67.3.
* gnu/packages/python-xyz.scm (python2-quex-0.67.3): Delete variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb20cfb52b..3f16b211c2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23094,48 +23094,6 @@ file system events on Linux.")
(define-public python2-pyinotify
(package-with-python2 python-pyinotify))
-;; Ada parser uses this version.
-(define-public python2-quex-0.67.3
- (package
- (name "python2-quex")
- (version "0.67.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/quex/HISTORY/"
- (version-major+minor version)
- "/quex-" version ".zip"))
- (sha256
- (base32
- "14gv8ll3ipqv4kyc2xiy891nrmjl4ic823zfyx8hassagyclyppw"))))
- (build-system python-build-system)
- (native-inputs
- (list unzip))
- (arguments
- `(#:python ,python-2
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share/quex (string-append out "/share/quex"))
- (bin (string-append out "/bin")))
- (copy-recursively "." share/quex)
- (mkdir-p bin)
- (symlink (string-append share/quex "/quex-exe.py")
- (string-append bin "/quex"))
- #t))))))
- (native-search-paths
- (list (search-path-specification
- (variable "QUEX_PATH")
- (files '("share/quex")))))
- (home-page "http://quex.sourceforge.net/")
- (synopsis "Lexical analyzer generator in Python")
- (description "@code{quex} is a lexical analyzer generator in Python.")
- (license license:lgpl2.1+))) ; Non-military
(define-public python2-quex
(package (inherit python2-quex-0.67.3)