summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-11-14 22:24:52 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-26 23:34:48 +0100
commitf3173bb901c0eee6c71d066cffab115d27052fc1 (patch)
treeb4e0fa6269e01f9a3210a2332fdf0f94e87a48dc /gnu/packages/python-xyz.scm
parentce74e02078b4d2753bf0205fae205a1b704b15d4 (diff)
gnu: Add python-canmatrix.
* gnu/packages/python-xyz.scm (python-canmatrix): New variable. Change-Id: I96192f7304388aefe1b5cc358d462d42120ca3a0 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a017b76d0..746ecccc5a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -145,6 +145,7 @@
;;; Copyright © c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2955,6 +2956,40 @@ abstractions to different hardware devices, and a suite of utilities for
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-canmatrix
+ (package
+ (name "python-canmatrix")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canmatrix" version))
+ (sha256
+ (base32 "046dzmggfm6h0fvfvwrblvih0blhc70ma0pqxzry3cphc08jvsrg"))
+ ;; The test suite uder ./test is a legacy test suite. The new test
+ ;; suite is defined under src/canmatrix/tests.
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "test"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-attrs python-click python-future
+ python-six))
+ (native-inputs (list python-lxml python-pytest python-xlrd python-xlwt))
+ (home-page "https://github.com/ebroecker/canmatrix")
+ (synopsis "@acronym{CAN, Controller Area Network} matrices in Python")
+ (description
+ "This package implements a @acronym{CAN, Controller Area Network} matrix
+object in Python which describes the CAN-communication and its needed objects
+such as board units, frames, signals, and values. It also includes two
+command-line tools (@command{canconvert} and @command{cancompare}) for
+converting and comparing CAN databases.")
+ (license license:bsd-2)))
+
(define-public python-canopen
(package
(name "python-canopen")