summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-01 17:16:39 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:07 -0400
commitb2ccd0dbf41ddae6d05f852d204342134dd4908e (patch)
tree47d7870d0bdb28ee1d210201d30165315ef93d59 /gnu/packages/ruby.scm
parent9b863bbd74eeca1439a3c2e0c7d2fcca28bc9a20 (diff)
gnu: ruby-oedipus-lex: Fix indentation.
* gnu/packages/ruby.scm (ruby-oedipus-lex): Fix indentation.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c88f98b3bb..9c45ca0c50 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5600,23 +5600,22 @@ development tools to catch coverage problems early.")
(name "ruby-oedipus-lex")
(version "2.6.0")
(source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "oedipus_lex" version))
- (sha256
- (base32
- "094nd7jd3klv45mvprfn2ivcgw8cckq3jhlly77j903vlamfi0df"))))
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oedipus_lex" version))
+ (sha256
+ (base32
+ "094nd7jd3klv45mvprfn2ivcgw8cckq3jhlly77j903vlamfi0df"))))
(build-system ruby-build-system)
- (native-inputs
- (list ruby-hoe))
+ (native-inputs (list ruby-hoe))
(synopsis "Ruby lexer")
(description
"Oedipus Lex is a lexer generator in the same family as Rexical and Rex.
It is based primarily on generating code much like you would a hand-written
lexer. It uses StrScanner within a multi-level case statement. As such,
Oedipus matches on the first match, not the longest.")
- (home-page "https://github.com/seattlerb/oedipus_lex")
- (license license:expat)))
+ (home-page "https://github.com/seattlerb/oedipus_lex")
+ (license license:expat)))
(define-public ruby-guard
(package