summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:01 +0200
commit7499f0f7a561be5de4797457e93f9e1b975ca74d (patch)
tree69dbfb035eb739b2962a7008f198d5b638b6bdfe /gnu/packages/tex.scm
parenta3689883d488e4aa82413777cfe3b44d19146862 (diff)
gnu: Add texlive-toolbox.
* gnu/packages/tex.scm (texlive-toolbox): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8e9ea045a4..d7df44c80b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98424,6 +98424,28 @@ be removed from each token; with this option, the @code{\\TrimSpaces} command
is defined, which removes leading and trailing spaces from its argument.")
(license license:lppl)))
+(define-public texlive-toolbox
+ (package
+ (name "texlive-toolbox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/toolbox/" "source/latex/toolbox/"
+ "tex/latex/toolbox/")
+ (base32
+ "08l1hn7ag065lmjlnap1kpa6xqppk24k81y0vm1ka45idwxi08ih")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/toolbox")
+ (synopsis "Tool macros")
+ (description
+ "This package provides some macros convenient for writing indexes,
+glossaries, or other macros. It contains macros which support: implicit
+macros; fancy optional arguments; loops over tokenlists and itemlists;
+searching and splitting; controlled expansion; redefinition of macros; and
+concatenated macro names; macros for text replacement.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar