summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-21 15:52:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-21 15:52:26 +0200
commit4dfea1010af3f00d424fe85384957d6405c8786e (patch)
tree604058bd34f49d43a9eadf324dfef29938760012 /gnu/packages/web.scm
parentb7a46ed22764db9097aba96e68143d46b2a75be0 (diff)
parenta34801ca685df32e1df50597a96a578acb66cfb0 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 19058de2d3..858ea1c759 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1025,17 +1025,16 @@ hash/signatures.")
(define-public libyaml
(package
(name "libyaml")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
(uri (string-append
"http://pyyaml.org/download/libyaml/yaml-"
version ".tar.gz"))
- (patches (search-patches "libyaml-CVE-2014-9130.patch"))
(sha256
(base32
- "0j9731s5zjb8mjx7wzf6vh7bsqi38ay564x6s9nri2nh9cdrg9kx"))))
+ "0a87931cx5m14a1x8rbjix3nz7agrcgndf4h392vm62a4rby9240"))))
(build-system gnu-build-system)
(home-page "http://pyyaml.org/wiki/LibYAML")
(synopsis "YAML 1.1 parser and emitter written in C")
@@ -3090,16 +3089,19 @@ exists it is used instead.")
(define-public perl-lwp-protocol-https
(package
(name "perl-lwp-protocol-https")
- (version "6.06")
+ (version "6.07")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/M/MS/MSCHILLI/"
+ (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
"LWP-Protocol-https-" version ".tar.gz"))
(sha256
(base32
- "1vxdjqj4bwq56m9h1bqqwkk3c6jr76f2zqzvwa26yjng3p686v5q"))))
+ "1rxrpwylfw1afah0nk96kgkwjbl2p1a7lwx50iipg8c4rx3cjb2j"))))
(build-system perl-build-system)
+ (native-inputs
+ ;; For tests.
+ `(("perl-test-requiresinternet" ,perl-test-requiresinternet)))
(propagated-inputs
`(("perl-io-socket-ssl" ,perl-io-socket-ssl)
("perl-libwww" ,perl-libwww)
@@ -3800,13 +3802,13 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(define-public r-httpuv
(package
(name "r-httpuv")
- (version "1.4.3")
+ (version "1.4.4.1")
(source (origin
(method url-fetch)
(uri (cran-uri "httpuv" version))
(sha256
(base32
- "15ghxcyg9h0za3qy077fnn3izbpihskvaqwsppm2s43a771imsf6"))))
+ "12kwq10xa8glrip7rai9xb4hnpysng00g2l0rw7swfzq5lk4z966"))))
(build-system r-build-system)
(native-inputs `(("r-rcpp" ,r-rcpp)))
(propagated-inputs