summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:15:11 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit09fb622cb36c2c8eb4163dfb4900c750461f0007 (patch)
tree0349c738c9ad8176150a7ce826cedf7b5a409f90 /gnu/packages
parent918f690a83af54d1735acd64f68149940ce694b9 (diff)
gnu: Add ghc-base-orphans.
* gnu/packages/haskell.scm (ghc-base-orphans): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f17ae3c60e..968438cc55 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1895,4 +1895,28 @@ simple general-purpose data structure\".")
command line options in Haskell.")
(license bsd-3)))
+(define-public ghc-base-orphans
+ (package
+ (name "ghc-base-orphans")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/base-orphans/base-orphans-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0hhgpwjvx7jhvlhsygmmf0q5hv2ymijzz4bjilicw99bmv13qcpl"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://hackage.haskell.org/package/base-orphans")
+ (synopsis "Orphan instances for backwards compatibility")
+ (description "This package defines orphan instances that mimic instances
+available in later versions of base to a wider (older) range of compilers.")
+ (license bsd-3)))
+
;;; haskell.scm ends here