summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:00 +0200
commit115f92af62842d27e3023dcb113bb3bc1878bbf0 (patch)
tree12b960adddbe1a945d872a1e1592d61392e64a62 /gnu/packages
parentb4a62d7e885ed21b14230c4bd241375b618c3f02 (diff)
gnu: jitterentropy-rngd: Use G-expressions.
* gnu/packages/linux.scm (jitterentropy-rngd)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2db3681e21..bf1c33db93 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2684,14 +2684,15 @@ Both commands are targeted at system administrators.")
(base32 "13br8s6gqnfc844ps38ya5nny3pndsmskszv3dsp1cxcgvmscg1c"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "UNITDIR=$(PREFIX)/lib/systemd/system")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no ./configure script
+ (list
+ #:tests? #f ; no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "UNITDIR=$(PREFIX)/lib/systemd/system")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no ./configure script
(home-page "https://www.chronox.de/jent.html")
(synopsis "CPU jitter random number generator daemon")
(description