summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-13 16:30:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:40 -0400
commit23a3ab5e760281031eaee0e4214a3a0b1f1f3dc8 (patch)
tree77080e17ffcec149b314c6dd9ab79486c55bf935 /gnu/packages
parentf00552b1b17fe8840c70e4058241ea7149b4c236 (diff)
gnu: Add ruby-pleaserun.
* gnu/packages/ruby.scm (ruby-pleaserun): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 07be7d7755..f6d328c56d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4119,6 +4119,48 @@ is known as @url{http://www.ietf.org/rfc/rfc2821.txt, RFC2821}.")
(home-page "https://github.com/ruby/net-smtp")
(license license:bsd-2)))
+(define-public ruby-pleaserun
+ (package
+ (name "ruby-pleaserun")
+ (version "0.0.32")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pleaserun" version))
+ (sha256
+ (base32
+ "1aykf0l8327bqkkf5xd9jcglsib973zpy37cfnlf4j0vp0cdpn2d"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'extract-gemspec 'relax-requirements
+ (lambda _
+ (substitute* "pleaserun.gemspec"
+ ;; Mustache is pinned at 0.99.8, for portability with
+ ;; older Rubies.
+ (("dependency\\(%q<mustache>.freeze.*")
+ "dependency(%q<mustache>.freeze)\n"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The cli_spec.rb test fails non-deterministically with
+ ;; a Errno::EISDIR error (see:
+ ;; https://github.com/jordansissel/pleaserun/issues/155)
+ (invoke "rspec" "--exclude-pattern" "cli_spec.rb")))))))
+ (native-inputs (list ruby-flores ruby-rspec))
+ (propagated-inputs (list ruby-cabin
+ ruby-clamp
+ ruby-dotenv
+ ruby-insist
+ ruby-mustache
+ ruby-stud))
+ (synopsis "Init scripts and service definitions generation tool")
+ (description "Pleaserun is a tool to generate startup scripts and service
+definitions. It targets service managers such as systemd, Upstart, launchd,
+sysv init, and runit.")
+ (home-page "https://github.com/jordansissel/pleaserun")
+ (license license:asl2.0)))
+
(define-public ruby-power-assert
(package
(name "ruby-power-assert")