summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-02-23 08:42:41 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:25 +0300
commit27c8dfbe27033f7cd3278d0f66e4e66d52136d3f (patch)
tree8621723dda813bdebf56f2306f696fe31c0b4d67 /gnu/packages
parentdac1915c7b889d91f640a36e0a35c6903877cd80 (diff)
gnu: Add rust-aes-ctr-0.6.
* gnu/packages/crates-io.scm (rust-aes-ctr-0.6): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0c8258cfe1..ac1d17cc23 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1973,6 +1973,32 @@ ciphers implementations.")
("rust-aesni" ,rust-aesni-0.6)
("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
+(define-public rust-aes-ctr-0.6
+ (package
+ (name "rust-aes-ctr")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aes-ctr" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0qspjxzrclnb83501595y01dhc0km1ssrbjnwlxhcrsdwp6w6abp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-soft" ,rust-aes-soft-0.6)
+ ("rust-aesni" ,rust-aesni-0.10)
+ ("rust-cipher" ,rust-cipher-0.2)
+ ("rust-ctr", rust-ctr-0.6))
+ #:cargo-development-inputs
+ (("rust-cipher" ,rust-cipher-0.2))))
+ (home-page "https://github.com/RustCrypto/block-ciphers/tree/master/aes")
+ (synopsis "Pure Rust implementation of AES")
+ (description "A pure Rust implementation of the Advanced Encryption Standard
+(AES). Use the aes crate if possible, as the aes-ctr has been deprecated.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-aes-gcm-0.10
(package
(name "rust-aes-gcm")