summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:37:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:38 +0200
commit28f384e85c93e16e8edaf4d8e0d96a287ae978f0 (patch)
tree4045947e5974d450b35e3897e1042c111d974f2a /gnu/packages
parent0110ef1c4efac93a1b8e2cffefdb39576f2907b2 (diff)
gnu: texlive-totpages: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-totpages!): Remove SIMPLE-TEXLIVE-PACKAGE call. [native-inputs]: Remove them.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm43
1 files changed, 18 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1453a3bd07..6d7bd82e6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13859,33 +13859,26 @@ changed, the recorded value will usually be the maximum value.")
(define-deprecated-package texlive-latex-totcount texlive-totcount)
(define-public texlive-totpages
- (let ((template (simple-texlive-package
- "texlive-totpages"
- (list "doc/latex/totpages/"
- "source/latex/totpages/"
- "tex/latex/totpages/")
- (base32
- "1mmya2fqdskyavw3hvdiygfyp9cll7bl4lpi7pl2jf9s7ds49j5a"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (build-system texlive-build-system)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t) "latex/totpages")
- ((#:tex-format _ #t) "latex")
- ((#:build-targets _ '()) '(list "totpages.ins"))))
- (native-inputs
- (list (texlive-updmap.cfg)))
- (propagated-inputs
- (list texlive-everyshi texlive-graphics))
- (home-page "https://ctan.org/pkg/totpages")
- (synopsis "Count pages in a document, and report last page number")
- (description
- "The package counts the actual pages in the document (as opposed to
+ (package
+ (name "texlive-totpages")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/totpages/" "source/latex/totpages/"
+ "tex/latex/totpages/")
+ (base32
+ "1mmya2fqdskyavw3hvdiygfyp9cll7bl4lpi7pl2jf9s7ds49j5a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (propagated-inputs (list texlive-everyshi texlive-graphics))
+ (home-page "https://ctan.org/pkg/totpages")
+ (synopsis "Count pages in a document, and report last page number")
+ (description
+ "The package counts the actual pages in the document (as opposed to
reporting the number of the last page, as does @code{lastpage}). The counter
itself may be shipped out to the DVI file.")
- (license license:lppl))))
+ (license license:lppl)))
(define-public texlive-xetexconfig
(package