summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-10 09:19:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:40 +0200
commit2994bd0e5ac93d34ad1a89bc319facf9f00d0c9b (patch)
treebc1fceabd5adf3dc5e77347f4d499425513724a3 /gnu/packages
parent35c54f7c092bb0b82267e3e9f1d41f80b7933c12 (diff)
gnu: Add texlive-letgut.
* gnu/packages/tex.scm (texlive-letgut): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 182374983c..77736a39cd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5183,6 +5183,36 @@ and commands.")
@code{latex2e-help-texinfo}.")
(license license:public-domain)))
+(define-public texlive-letgut
+ (package
+ (name "texlive-letgut")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/letgut/"
+ "source/lualatex/letgut/"
+ "tex/lualatex/letgut/")
+ (base32
+ "1wk6bibz59jw9vx2syq0hfi2yz69kr3w87839bhnl3svz2x958nn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/letgut")
+ (synopsis
+ "Class for the newsletter @code{La Lettre GUTenberg} of the French TeX User
+Group GUTenberg")
+ (description
+ "The French TeX User Group GUTenberg has been publishing @emph{The
+GUTenberg Letter}, its irregular newsletter, since February 1993. For this
+purpose, a dedicated, in-house (La)TeX class was gradually created but,
+depending on new needs and on the people who were publishing the Newsletter,
+its development was somewhat erratic; in particular, it would not have been
+possible to publish its code as it was. In addition, its documentation was
+non-existent. The Board of Directors of the association, elected in November
+2020, wished to provide a better structured, more perennial and documented
+class, able to be published on the CTAN. This is now done with the present
+@code{letgut} class.")
+ (license license:lppl1.3c)))
+
(define-public texlive-letterswitharrows
(package
(name "texlive-letterswitharrows")