summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:19:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:08:58 +0200
commit2e54bebc6aaf52944ba312179bb8bc0a83d46366 (patch)
treeb83767bd6712742f8233d7e26d99f296c0d3e678 /gnu/packages
parent1f5c55b6ab2ff61b9b4219641cd63ee0573b41f7 (diff)
gnu: Add texlive-ptex-base.
* gnu/packages/tex.scm (texlive-ptex-base): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 336c2080e1..57557a3747 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13471,6 +13471,23 @@ problems in typesetting Japanese. A manual (in both Japanese and English) is
distributed as package @code{pTeX-manual}.")
(license license:bsd-3)))
+(define-public texlive-ptex-base
+ (package
+ (name "texlive-ptex-base")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/ptex/ptex-base/" "tex/ptex/ptex-base/")
+ (base32
+ "0hfccpsfpj56v97056k77lyb09az7m24m8klf1n2v0a7kqdc1fv6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ptex-base")
+ (synopsis "Plain TeX format for pTeX and e-pTeX")
+ (description
+ "The bundle contains the plain TeX format for pTeX and e-pTeX.")
+ (license license:bsd-3)))
+
(define-public texlive-ptex-fonts
(package
(name "texlive-ptex-fonts")