summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:42:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:14 +0200
commit311676f83d04e2393a295e38d3a846497332370f (patch)
tree14e7ce942441c4876fdf2e4044261e4c63e1031a /gnu/packages
parent25b88b9f221c392ce476b63947169b5ca807dc79 (diff)
gnu: Add texlive-pseudocode.
* gnu/packages/tex.scm (texlive-pseudocode): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 862ebf5ace..3d252b0754 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5668,6 +5668,25 @@ and highlighting, and there is functionality for typesetting common syntactic
elements such as keywords, identifiers, and comments.")
(license license:expat)))
+(define-public texlive-pseudocode
+ (package
+ (name "texlive-pseudocode")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pseudocode/"
+ "tex/latex/pseudocode/")
+ (base32
+ "180m5yja3wkdnpfz0qx9m031qmhqyjjjgxynm3v4y8fz9jz7vidq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pseudocode")
+ (synopsis "LaTeX environment for specifying algorithms in a natural way")
+ (description
+ "This package provides the environment @code{pseudocode} for describing
+algorithms in a natural manner.")
+ (license license:lppl)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")