summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:00 +0300
commit391f78abfcb9a61a79300ce31836ed6414223b6c (patch)
tree0210d4cac7e20c791925abf47a7f56a91bb680e5 /gnu/packages
parente201e66ba7c025b939f2538574ec8352f5802226 (diff)
gnu: Add rust-p256-0.13.
* gnu/packages/crates-io.scm (rust-p256-0.13): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 45cf16027b..2ef27ebdc9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -42425,6 +42425,43 @@ owner with them. This can sometimes be useful because Rust borrowing rules
normally prevent moving a type that has been borrowed from.")
(license license:expat)))
+(define-public rust-p256-0.13
+ (package
+ (name "rust-p256")
+ (version "0.13.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "p256" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jyd3c3k239ybs59ixpnl7dqkmm072fr1js8kh7ldx58bzc3m1n9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-primeorder" ,rust-primeorder-0.13)
+ ("rust-serdect" ,rust-serdect-0.2)
+ ("rust-sha2" ,rust-sha2-0.10))
+ #:cargo-development-inputs
+ (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-criterion" ,rust-criterion-0.4)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-primeorder" ,rust-primeorder-0.13)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-rand-core" ,rust-rand-core-0.6))))
+ (home-page
+ "https://github.com/RustCrypto/elliptic-curves/tree/master/p256")
+ (synopsis "Pure Rust implementation of the NIST P-256")
+ (description
+ "This package provides a pure Rust implementation of the NIST P-256 (a.k.a.
+secp256r1, prime256v1) elliptic curve as defined in SP 800-186, with support for
+ECDH, ECDSA signing/verification, and general purpose curve arithmetic.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-p384-0.13
(package
(name "rust-p384")