summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:01 +0300
commit43121f5bd39088584f23e00bee3f9aa815907048 (patch)
treeff69b1f470924bc6b71e56b106c7024cf1705a0f /gnu/packages
parente1b825fe4b980599d5dd6e30e9dec196716ab358 (diff)
gnu: Add rust-idea-0.5.
* gnu/packages/crates-io.scm (rust-idea-0.5): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e1edfb0bc2..6a94c63eb3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29510,6 +29510,26 @@ with hyper.")
"This package provides the IANA time zone for the current system.")
(license (list license:expat license:asl2.0))))
+(define-public rust-idea-0.5
+ (package
+ (name "rust-idea")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "idea" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xv4hd9mgrwgzfl7cc5nlwyahm9yni5z9dwb3c1z5mqr8h05fm87"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cipher" ,rust-cipher-0.4))
+ #:cargo-development-inputs (("rust-cipher" ,rust-cipher-0.4))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "IDEA block cipher")
+ (description "IDEA block cipher")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-ident-case-1
(package
(name "rust-ident-case")