summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 14:04:13 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:51 +0530
commit5872e71db7e0542a8011d3b34dc56aa44ffae9bf (patch)
tree85058f1e2ed258c55cfa8155f4312a2912a404fc /gnu/packages
parent3dd1843675c0bb287c8113fb171cc8b8ca3b3ef4 (diff)
gnu: Add rust-hash32-derive-0.1.
* gnu/packages/crates-io.scm (rust-hash32-derive-0.1): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 55b964e9b3..2a93d77c50 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10060,6 +10060,30 @@ IEEE 754-2008 binary16 type.")
the template engine that renders the official Rust website")
(license license:expat)))
+(define-public rust-hash32-derive-0.1
+ (package
+ (name "rust-hash32-derive")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hash32-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18lrlxycq45kaz0l688shxnhgh3ryjp3zn0n6vfcs5sa2nyyzh7b"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-0.3)
+ ("rust-quote" ,rust-quote-0.5)
+ ("rust-syn" ,rust-syn-0.13))))
+ (home-page "https://github.com/japaric/hash32")
+ (synopsis "Macros 1.1 implementation of @code{#[derive(Hash32)]}")
+ (description "This package provides a macros 1.1 implementation of
+@code{#[derive(Hash32)]}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hashbrown-0.5
(package
(name "rust-hashbrown")