summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-18 23:02:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 10:46:30 +0300
commit5f23551e6df1ed6ab3ba5ce4dd36873396c9e8d2 (patch)
treee84e97a69e2227e405ff2cddb0b11cf48289478a /gnu/packages
parent1f6981d33220a0c13a4b3453c31d10a0d6369c31 (diff)
gnu: Remove rust-win-crypto-ng-0.4.
* gnu/packages/crates-io.scm (rust-win-crypto-ng-0.4): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 69e49be171..76f2f2dccc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69921,42 +69921,6 @@ color in a Windows console.")
#:cargo-inputs
(("rust-winapi" ,rust-winapi-0.3))))))
-(define-public rust-win-crypto-ng-0.4
- (package
- (name "rust-win-crypto-ng")
- (version "0.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "win-crypto-ng" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0v26ssjip8fdilj1j6csnvcny98gb90ra1qlnm2xwjlgivlr5kr4"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-cipher" ,rust-cipher-0.2)
- ("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-rand-core" ,rust-rand-core-0.5)
- ("rust-winapi" ,rust-winapi-0.3)
- ("rust-zeroize" ,rust-zeroize-1))))
- (home-page "https://crates.io/crates/win-crypto-ng")
- (synopsis "Safe bindings to MS Windows Cryptography API Next
-Generation")
- (description
- "Cryptography API Next Generation (CNG) are cryptographic
-primitives and utilities provided by the operating system and/or
-hardware. It is available since Windows Vista and replaces the now
-deprecated CryptoAPI.
-
-The primitives do not depend on OpenSSL or other libraries of the
-sort, they are provided by Microsoft and/or by the hardware
-manufacturer. They are the primitives used in kernel space programs.
-Therefore, if you are using Microsoft Windows, you already accepted to
-trust these primitives.")
- (license license:bsd-3)))
-
(define-public rust-winpty-sys-0.4
(package
(name "rust-winpty-sys")