summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-09 14:39:25 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:30 -0400
commit62247577bd301b066ccbce11d9a570397841e1bd (patch)
treec7879f75e1fddccc02cddf94674dde1a7b6b31dc /gnu/packages
parentd4cd510db71b3235b5a43b15f5eff609d654199d (diff)
gnu: Add ruby-rspec-debug.
* gnu/packages/ruby.scm (ruby-rspec-debug): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6141a69429..c6cabf313a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -993,6 +993,37 @@ expectations and mocks frameworks.")
(propagated-inputs
(list ruby-rspec-core-2 ruby-rspec-mocks-2 ruby-rspec-expectations-2))))
+(define-public ruby-rspec-debug
+ (package
+ (name "ruby-rspec-debug")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ko1/rspec-debug")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "125p1zxjznkk765nyqvkksw8x1nbm7xk4sjc1wza2fyp5hvyiddn"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:test-target "spec"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'extract-gemspec 'relax-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ (("~>") ">=")))))))
+ (native-inputs (list ruby-rspec))
+ (propagated-inputs (list ruby-debug))
+ (synopsis "Invoke Ruby debugger when spec fails")
+ (description "This package can be used to have the execution stopped for
+inspection in the Ruby debugger upon encountering a failure. To use it, set
+the @env{RSPEC_DEBUG} environment variable to @samp{true} then invoke the
+@command{rspec} command as usual.")
+ (home-page "https://github.com/ko1/rspec-debug")
+ (license license:expat)))
+
;; Bundler is yet another source of circular dependencies, so we must disable
;; its test suite as well.
(define-public bundler