summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-09 23:48:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-10 15:44:20 +0200
commit6ef2b32612ba08600fb0c7ab4a123c27201a4fc9 (patch)
treea0e33911b433a914325aa3ef5c7f3905a86bdb54 /gnu/packages
parente7bb12c0a4cb5bf3edb0eefe32d4b4430ebbe672 (diff)
gnu: r-flexdashboard: Update to 0.6.0.
* gnu/packages/cran.scm (r-flexdashboard): Update to 0.6.0. [source]: Delete featherlight.min.js. [arguments]: Remove trailing #T. [propagated-inputs]: Add r-bslib, r-sass, and r-scales.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7aa223388..953866fe7f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19479,14 +19479,14 @@ etc.). Text boxes with automatic word wrap are also supported.")
(define-public r-flexdashboard
(package
(name "r-flexdashboard")
- (version "0.5.2")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "flexdashboard" version))
(sha256
(base32
- "1bh759llp15fxrx2rwvxd8p3w84vjmkid32ism7zg49a127fjib4"))
+ "0bvw2ca6xxscia4hvq505qvjf6zkgpsqv86f1s78aknzwr9jsikm"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -19495,7 +19495,7 @@ etc.). Text boxes with automatic word wrap are also supported.")
(delete-file "inst/www/sly/sly.min.js")
(delete-file "inst/www/stickytableheaders/jquery.stickytableheaders.min.js")
(delete-file "inst/www/prism/prism.js")
- #t))))
+ (delete-file "inst/www/featherlight/featherlight.min.js")))))
(build-system r-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -19542,14 +19542,16 @@ etc.). Text boxes with automatic word wrap are also supported.")
(call-with-output-file target
(lambda (port)
(dump-port minified port)))))
- sources targets))))
- #t)))))
+ sources targets)))))))))
(propagated-inputs
- (list r-htmltools
+ (list r-bslib
+ r-htmltools
r-htmlwidgets
r-jsonlite
r-knitr
r-rmarkdown
+ r-sass
+ r-scales
r-shiny))
(native-inputs
`(("uglifyjs" ,node-uglify-js)