summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 18:13:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:34 +0200
commit7d41edfba314790b80a773b358da3e9a8a80eff0 (patch)
tree05a078f55a98613dafe985d392143367e039b447 /gnu/packages
parent140a8be632fbe7b31674af72cef9493b3f394e8c (diff)
gnu: Add texlive-apprendre-a-programmer-en-tex.
* gnu/packages/tex.scm (texlive-apprendre-a-programmer-en-tex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82483a05d2..e021099ba4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1602,6 +1602,26 @@ Operands may be numbers with arbitrary numbers of digits; scientific notation
is allowed. The expression scanner is also provided.")
(license license:public-domain)))
+(define-public texlive-apprendre-a-programmer-en-tex
+ (package
+ (name "texlive-apprendre-a-programmer-en-tex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/apprendre-a-programmer-en-tex/")
+ (base32
+ "05779lk9v849k712wfjv0mhyzahwpl4n892ydamfdc5yg05bsnyv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/apprendre-a-programmer-en-tex")
+ (synopsis "@emph{Apprendre à programmer en TeX} book")
+ (description
+ "This book explains the basic concepts required for programming in TeX
+and explains the programming methods, providing many examples. The package
+makes the compileable source code as well as the compiled PDF file accessible
+to everyone.")
+ (license license:lppl1.2+)))
+
(define-public texlive-apxproof
(package
(name "texlive-apxproof")