summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:42:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:17 +0200
commit826c56ded2fe3d5b7c72face5c9f225b529b99d8 (patch)
tree9ea9053df7522cf4ec8f597afd8c47940409c512 /gnu/packages
parentf1ab2c8fa2e5623c3bbd0bbbbc4bff7d356e9115 (diff)
gnu: Add rust-malloc-buf-1.
* gnu/packages/crates-io.scm (rust-malloc-buf-1): New variable. (rust-malloc-buf-0.0): Inherit from rust-malloc-buf-1. Change-Id: I64054134b287db00f416fd4731d31c693c0ae354
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm53
1 files changed, 33 insertions, 20 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5540d81625..1b3a63298a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38991,27 +38991,40 @@ algorithms. It supports CBC block cipher mode, PKCS5 padding and 64, 128,
("rust-charset" ,rust-charset-0.1)
("rust-quoted-printable" ,rust-quoted-printable-0.4))))))
+(define-public rust-malloc-buf-1
+ (package
+ (name "rust-malloc-buf")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "malloc_buf" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1zap9m0xmd5sdsxil7v2rgb1dzlq0308f826pwvqdvjyaz0chciz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/SSheldon/malloc_buf")
+ (synopsis "Structs for handling malloc'd memory passed to Rust")
+ (description
+ "This package provides structs for handling malloc'd memory passed to Rust.")
+ (license license:expat)))
+
(define-public rust-malloc-buf-0.0
- (package
- (name "rust-malloc-buf")
- (version "0.0.6")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "malloc_buf" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1jqr77j89pwszv51fmnknzvd53i1nkmcr8rjrvcxhm4dx1zr1fv2"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
- (home-page "https://github.com/SSheldon/malloc_buf")
- (synopsis "Structs for handling malloc'd memory passed to Rust")
- (description
- "This package provides structs for handling malloc'd memory passed to Rust.")
- (license license:expat)))
+ (package
+ (inherit rust-malloc-buf-1)
+ (name "rust-malloc-buf")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "malloc_buf" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1jqr77j89pwszv51fmnknzvd53i1nkmcr8rjrvcxhm4dx1zr1fv2"))))
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))))
(define-public rust-maplit-1
(package