summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-22 21:01:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:11 +0300
commita06d5ef0fe025db680e3123104487e8f42de1767 (patch)
treeec18ecbb0169bd1109492087b7bf0b5cc5783244 /gnu/packages
parent182400d82f12e316cfd0a05a5b207481d53f71c5 (diff)
gnu: Add rust-ntest-proc-macro-helper-0.8.
* gnu/packages/crates-io.scm (rust-ntest-proc-macro-helper-0.8): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 86dd709e70..7c41daa81b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37987,6 +37987,23 @@ framework.")
("rust-syn" ,rust-syn-1)
("rust-timebomb" ,rust-timebomb-0.1))))))
+(define-public rust-ntest-proc-macro-helper-0.8
+ (package
+ (name "rust-ntest-proc-macro-helper")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "ntest-proc-macro-helper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "154r3r9nnnp6qjzlayc54213bdrgdk8b68jjnn1xcyd6cz92iqx0"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/becheran/ntest")
+ (synopsis "Helper functions for the procedural macros used in ntest")
+ (description "This package provides helper functions for the procedural
+macros used in ntest.")
+ (license license:expat)))
+
(define-public rust-num-0.4
(package
(name "rust-num")