summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-05-11 18:04:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 09:17:07 +0200
commita5bae9c7486b88c6b416cbd74dc0c7990fb10f73 (patch)
treeff5fdb4fe9eedd959826306e0c84851d05be000f /gnu/packages
parent6c6e2b5fbc79ede6377c0716ed87857942cb6760 (diff)
gnu: Add r-ggpattern.
* gnu/packages/cran.scm (r-ggpattern): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b4c9065c1d..4fafcaea9c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20192,6 +20192,36 @@ The flagship function is @code{ggMarginal()}, which can be used to add
marginal histograms/boxplots/density plots to ggplot2 scatterplots.")
(license license:expat)))
+(define-public r-ggpattern
+ (package
+ (name "r-ggpattern")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggpattern" version))
+ (sha256
+ (base32 "1b9bfxlg64gr39bz58fp6jmg4nziwk8rk94rzpjsqhfhpwi2lrgr"))))
+ (properties `((upstream-name . "ggpattern")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-glue
+ r-gridpattern
+ r-rlang
+ r-scales))
+ (native-inputs (list r-knitr r-ragg r-rmarkdown))
+ (home-page "https://github.com/coolbutuseless/ggpattern")
+ (synopsis "Ggplot2 pattern geoms")
+ (description
+ "This package provides ggplot2 geoms filled with various patterns.
+It includes a patterned version of every ggplot2 geom that has a region that
+can be filled with a pattern. It provides a suite of ggplot2 aesthetics and
+scales for controlling pattern appearances. It supports over a dozen builtin
+patterns (every pattern implemented by gridpattern) as well as allowing custom
+user-defined patterns.")
+ (license license:expat)))
+
(define-public r-minpack-lm
(package
(name "r-minpack-lm")